Fecha y hora actual: Lunes 16 Jul 2018 12:14
Índice del Foro

Foros de programación informática, diseño gráfico y Web

En esta comunidad intentaremos dar soporte de programación a todos los niveles, desde principiantes a profesionales de la informática, desarrollo de programas, programación web y mucho más.

Ayuda con TestNG Parametrico en java netbeans

Responder al Tema

Índice del Foro > Java > Ayuda con TestNG Parametrico en java netbeans

Autor Mensaje
baltigo



Registrado: 30 Jun 2018
Mensajes: 1

Mensaje Publicado: Sábado 30 Jun 2018 01:37

Título del mensaje: Ayuda con TestNG Parametrico en java netbeans

Responder citando

Hola buen dia a todos estoy iniciando con programacion y lo que me complica mas son los la verificacion de resultados con un testing parametrico con la biblioteca TestNG no me manejo mucho en los test si alguien me podria ayudar o guiar se lo agradeceria mucho gracias ; )


en pseudocodigo lo tengo asi

Algoritmo Monedas
Escribir "Precio del Pdcto A $270";
Escribir "Precio del Pdcto B $340";
Escribir "Precio del Pdcto C $390";
Escribir Sin Saltar "Ingresa el código A, B o C";
leer codigoProducto;
si(codigoProducto <> "A" && codigoProducto<>"B" && codigoProducto<>"C")entonces
Escribir "Error de Ingreso";
Sino
Si codigoProducto="A" Entonces
precio=270;
SiNo
Si codigoProducto="B" Entonces
precio=340;
SiNo
precio=390;
FinSi
FinSi
Escribir "Ingresa las monedas (10) - (50) - (100)";
montoMonedas=0;
Mientras montoMonedas<precio Hacer
Escribir Sin Saltar "Ingresa una moneda";
leer moneda;
montoMonedas=montoMonedas+moneda;
FinMientras
Escribir "El vuelto es:";

montoMonedas=montoMonedas-precio;

vueltoMonedaCincuenta=trunc(montoMonedas/50);
vueltoMonedaDiez=trunc((montoMonedas mod 50)/10);


para i=1 hasta vueltoMonedaCincuenta con paso 1 hacer
escribir 50;
FinPara

para i=1 hasta vueltoMonedaDiez con paso 1 hacer
escribir 10;
FinPara

FinSi
FinAlgoritmo


------------------------------------------------------------------------JAVA--------------------------------------------------------------------







Scanner sca = new Scanner(System.in);



String codigoproducto;
double i;
double moneda;
double montomonedas;
double precio;
int vueltomonedacincuenta;
int vueltomonedadiez;



public String Exec(){
System.out.println("Precio del Producto A $270");
System.out.println("Precio del Producto B $340");
System.out.println("Precio del Producto C $390");
System.out.print("Ingresa el código A, B o C");
codigoproducto = sca.next();
if((("A".equals(codigoproducto)) && ("B".equals(codigoproducto))) && ("C".equals(codigoproducto))) {
System.out.println("Error de Ingreso");
} else {
if (codigoproducto.equals("A")) {
precio = 270;
} else {
if (codigoproducto.equals("B")) {
precio = 340;
} else {
precio = 390;
}
}
System.out.println("Ingresa las monedas (10) - (50) - (100)" );
montomonedas = 0;
while (montomonedas<precio) {
System.out.print("Ingresa una moneda");
moneda = Double.parseDouble(sca.next());
montomonedas = montomonedas+moneda;
}{}
System.out.println("El vuelto es:");
montomonedas = montomonedas-precio;
vueltomonedacincuenta = (int) Math.floor(montomonedas/50);
vueltomonedadiez = (int) Math.floor((montomonedas%50)/10);
for (i=1;i<=vueltomonedacincuenta;i++) {
System.out.println(50);
}
for (i=1;i<=vueltomonedadiez;i++) {
System.out.println(10);
}
}
return "Cambio Terminado";
}
}

Volver arriba
Ver perfil del usuario Enviar mensaje privado
Responder al Tema
Mostrar mensajes anteriores:   
Ir a:  
Todas las horas están en GMT + 2 Horas

Temas relacionados

Tema Autor Foros Respuestas Publicado
El foro no contiene ningún mensaje nuevo

AYUDA: COMO RECONECTO VB6 A MYSQL SIN PERDER LA...

rjaguin Visual Basic y VBA 0 Miércoles 09 May 2018 22:27 Ver último mensaje
El foro no contiene ningún mensaje nuevo

AYUDA CON UN SCRIPT

daniel159762 S.O. Linux 0 Miércoles 15 Nov 2017 19:08 Ver último mensaje
El foro no contiene ningún mensaje nuevo

Ayuda con array foreach

Pedrolo PHP 1 Miércoles 08 Nov 2017 18:40 Ver último mensaje
El foro no contiene ningún mensaje nuevo

Publicar Aplicación web JAVA en tomcat

Irvin Java Web 1 Viernes 13 Oct 2017 17:54 Ver último mensaje
El foro no contiene ningún mensaje nuevo

Ayuda Programar Ruleta con tablero en Netbeans

Danielilla Java 0 Jueves 12 Oct 2017 05:41 Ver último mensaje
Panel de Control
No puede crear mensajes, No puede responder temas, No puede editar sus mensajes, No puede borrar sus mensajes, No puede votar en encuestas,