Fecha y hora actual: Martes 14 Ago 2018 10:37
Índice del Foro

Foros de programación informática, diseño gráfico y Web

En esta comunidad intentaremos dar soporte de programación a todos los niveles, desde principiantes a profesionales de la informática, desarrollo de programas, programación web y mucho más.

pseint me redondea el resultado

Responder al Tema

Índice del Foro > Pseudocódigo o notación pseudocodificada > pseint me redondea el resultado

Autor Mensaje
serialkills



Registrado: 02 Ago 2018
Mensajes: 1

Mensaje Publicado: Jueves 02 Ago 2018 12:43

Título del mensaje: pseint me redondea el resultado

Responder citando

Algoritmo Calculadora_De_Dimensiones
Escribir 'Dimensiones'
Definir resultado1 como real
Definir resultado2 como real
Definir resultado3 como real
Definir tot Como Real
Definir n1 como real
Definir r1 como real
Definir n2 como real
Definir r2 como real
Definir n3 como real
Definir r3 como real
Definir n4 como real
Definir r4 como real
Definir n5 como real
Definir r5 como real
Definir n6 como real
Definir r6 como real
Definir res Como Real



Repetir
resultado3 <- resultado3
tot <- tot
tot <- tot+resultado3
Escribir 'ingrese un numero de 3 a 6 cifras, Escribe 0 para salir'
Leer a

resultado3 <- Numerico


Si a<1000 Entonces
n1 <- trunc(a/100)
r1 <- a MOD 100
n2 <- trunc(r1/10)
r2 <- a MOD 10
n3 <- trunc(r2/1)

union1 <- n1*n2
union2 <- union1*n3
resultado3 <- union2/12
SiNo
Si a>999 Y a<9999 Entonces
n1 <- trunc(a/1000)
r1 <- a MOD 1000
n2 <- trunc(r1/100)
r2 <- a MOD 100
n3 <- trunc(r2/10)
r3 <- a MOD 10
n4 <-trunc(r3/1)

union1 <-n2
resultado1 <- n1*n2
res<-n3*10+n4
resultado2 <- resultado1*res
resultado3 <- resultado2/12
SiNo
Si a>9999 y a<99999 Entonces
n1 <- trunc(a/10000)
r1 <- a MOD 10000
n2 <- trunc(r1/1000)
r2 <- a MOD 1000
n3 <- trunc(r2/100)
r3 <- a MOD 100
n4 <-trunc(r3/10)
r4 <- a MOD 10
n5 <-trunc(r4/1)


union1 <-n2*10+n3
union2 <-n4*10+n5
resultado1 <- n1*union1
resultado2 <- resultado1*union2
resultado3 <- resultado2/12






SiNo
Si a>99999 y a <999999 Entonces

n1 <- trunc(a/100000)
r1 <- a MOD 100000
n2 <- trunc(r1/10000)
r2 <- a MOD 10000
n3 <- trunc(r2/1000)
r3 <- a MOD 1000
n4 <- trunc(r3/100)
r4 <- a MOD 100
n5 <- trunc(r4/10)
r5 <- a Mod(10)
n6 <- trunc (r5/1)


union1 <- n1*10+n2
union2 <- n3*10+n4
union3 <-n5*10+n6

resultado1 <- union1*union2
resultado2 <- union3*resultado1
resultado3 <- resultado2/12



FinSi
FinSi
FinSi
FinSi
// Escribir 'el digito de los numeros ingresados es ',n1,n2,n3,n4,n5
// Escribir 'segunda cifra es ',union1
Escribir 'el resultado convertido a (P) es ',resultado3
Hasta Que resultado3=0
Escribir 'Total:',tot
FinAlgoritmo

he testeado con 41410 3 veces y veran que sale 140 en vez 139.8

Volver arriba
Ver perfil del usuario Enviar mensaje privado
Responder al Tema
Mostrar mensajes anteriores:   
Ir a:  
Todas las horas están en GMT + 2 Horas

Temas relacionados

Tema Autor Foros Respuestas Publicado
El foro no contiene ningún mensaje nuevo

Guardar resultado ASP en formato XML

Registros_r2 ASP, ASP.NET 0 Lunes 15 Ene 2018 15:56 Ver último mensaje
El foro no contiene ningún mensaje nuevo

resultado separado por comas y al final un punto

pegomezca Python 0 Lunes 23 Oct 2017 11:19 Ver último mensaje
El foro no contiene ningún mensaje nuevo

Guardar el resultado de una consulta en base de...

Manuel Vazquez Visual Basic .NET 0 Miércoles 20 Jul 2016 23:48 Ver último mensaje
El foro no contiene ningún mensaje nuevo

Ayuda pseint

ripper Pseudocódigo o notación pseudocodificada 0 Sábado 18 Jun 2016 00:59 Ver último mensaje
El foro no contiene ningún mensaje nuevo

ayuda para pseint

willyrex99 Pseudocódigo o notación pseudocodificada 0 Miércoles 25 Mar 2015 00:02 Ver último mensaje
Panel de Control
No puede crear mensajes, No puede responder temas, No puede editar sus mensajes, No puede borrar sus mensajes, No puede votar en encuestas,